summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-12-11 04:43:35 +0300
committerMark Wielaard <mark@klomp.org>2020-12-11 12:47:54 +0100
commit441d2f09e1a9a27451ccf9b20a2be3bb3d1986c1 (patch)
tree194cf20a9ed8ff27fc57435759bf94a9d31a4bce /tests/Makefile.am
parentbe084ccb5507e0c092ac4e434026a4d47e9007bf (diff)
downloadelfutils-441d2f09e1a9a27451ccf9b20a2be3bb3d1986c1.tar.gz
Remove unused tests/configure.ac
tests/configure.ac was introduced 15 years ago by commit d7f8d0caa7a357f9f4765e5dc93255f5057eba2e. However, the ability to build tests as a separate project was broken by the same author 4 years later by commit 22359e265395fd2f8267190ef97f5417770e6206, if not earlier. An attempt to run autoreconf in tests would currently fail with the following automake error: automake: error: cannot open < config/eu.am: No such file or directory Apparently, nobody builds tests as a separate project for more than 10 years, so cleanup the remains of that unused and broken code. Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am36
1 files changed, 7 insertions, 29 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 84f6e88e..3cca2251 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,15 +19,11 @@
include $(top_srcdir)/config/eu.am
BUILD_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
-AM_LDFLAGS =
-
-if !STANDALONE
AM_CPPFLAGS += -I$(top_srcdir)/libasm -I$(top_srcdir)/libdw \
-I$(top_srcdir)/libdwfl -I$(top_srcdir)/libdwelf \
-I$(top_srcdir)/libebl -I$(top_srcdir)/libelf \
-I$(top_srcdir)/lib -I..
-AM_LDFLAGS += -Wl,-rpath-link,../libasm:../libdw:../libelf
-endif
+AM_LDFLAGS = -Wl,-rpath-link,../libasm:../libdw:../libelf
if TESTS_RPATH
AM_LDFLAGS += -Wl,-rpath,$(BUILD_RPATH)
@@ -63,7 +59,9 @@ check_PROGRAMS = arextract arsymtest newfile saridx scnnames sectiondump \
all-dwarf-ranges unit-info next_cfi \
elfcopy addsections xlate_notes elfrdwrnop \
dwelf_elf_e_machine_string \
- getphdrnum leb128 read_unaligned
+ getphdrnum leb128 read_unaligned \
+ msg_tst system-elf-libelf-test \
+ $(asm_TESTS)
asm_TESTS = asm-tst1 asm-tst2 asm-tst3 asm-tst4 asm-tst5 \
asm-tst6 asm-tst7 asm-tst8 asm-tst9
@@ -186,7 +184,9 @@ TESTS = run-arextract.sh run-arsymtest.sh run-ar.sh newfile test-nlist \
run-disasm-riscv64.sh \
run-pt_gnu_prop-tests.sh \
run-getphdrnum.sh run-test-includes.sh \
- leb128 read_unaligned
+ leb128 read_unaligned \
+ msg_tst system-elf-libelf-test \
+ $(asm_TESTS) run-disasm-bpf.sh
if !BIARCH
export ELFUTILS_DISABLE_BIARCH = 1
@@ -196,11 +196,6 @@ if !DEMANGLE
export ELFUTILS_DISABLE_DEMANGLE = 1
endif
-if !STANDALONE
-check_PROGRAMS += msg_tst system-elf-libelf-test
-TESTS += msg_tst system-elf-libelf-test
-endif
-
if LZMA
TESTS += run-readelf-s.sh run-dwflsyms.sh
endif
@@ -209,11 +204,6 @@ if HAVE_ZSTD
TESTS += run-readelf-compressed-zstd.sh
endif
-if HAVE_LIBASM
-check_PROGRAMS += $(asm_TESTS)
-TESTS += $(asm_TESTS) run-disasm-bpf.sh
-endif
-
if DEBUGINFOD
check_PROGRAMS += debuginfod_build_id_find
# With the dummy delegation doesn't work
@@ -539,10 +529,6 @@ installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir); \
installed_LOG_COMPILER = $(abs_srcdir)/test-wrapper.sh \
installed $(tests_rpath) \
'$(program_transform_name)'
-if STANDALONE
-TESTS_ENVIRONMENT = $(installed_TESTS_ENVIRONMENT)
-LOG_COMPILER = $(installed_LOG_COMPILER)
-else !STANDALONE
TESTS_ENVIRONMENT = LC_ALL=C; LANG=C; VALGRIND_CMD=$(valgrind_cmd); \
abs_srcdir=$(abs_srcdir); abs_builddir=$(abs_builddir); \
abs_top_builddir=$(abs_top_builddir); \
@@ -558,14 +544,7 @@ installcheck-local:
$(MAKE) $(AM_MAKEFLAGS) \
TESTS_ENVIRONMENT="$(installed_TESTS_ENVIRONMENT)" \
LOG_COMPILER="$(installed_LOG_COMPILER)" check-TESTS
-endif !STANDALONE
-if STANDALONE
-libdw = -ldw
-libelf = -lelf
-libasm = -lasm
-libebl = -lebl
-else !STANDALONE
if BUILD_STATIC
libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
libelf = ../libelf/libelf.a -lz
@@ -577,7 +556,6 @@ libasm = ../libasm/libasm.so
endif
libebl = ../libebl/libebl.a ../backends/libebl_backends.a ../libcpu/libcpu.a
libeu = ../lib/libeu.a
-endif !STANDALONE
arextract_LDADD = $(libelf)
arsymtest_LDADD = $(libelf)