summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2020-10-25 20:40:33 +0100
committerMark Wielaard <mark@klomp.org>2020-10-30 00:12:05 +0100
commit4c39dc18bbba4801c016c0b24d03d697fb14aa24 (patch)
tree68fdd9b49ad74d261f638f837e4f55738e246c0f /tests/Makefile.am
parent70343f484481184f9fa216071399690ff833256b (diff)
downloadelfutils-4c39dc18bbba4801c016c0b24d03d697fb14aa24.tar.gz
tests: Add read_unaligned testcase
Run tests/read_unaligned 1 on a big endian and little endian machine to generate the le_mem and be_mem arrays. The one byte variants are kind of impossible to get wrong, but including them makes sure the other variants are not naturally aligned in memory. Signed-off-by: Mark Wielaard <mark@klomp.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1b51ab8d..84f6e88e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -63,7 +63,7 @@ check_PROGRAMS = arextract arsymtest newfile saridx scnnames sectiondump \
all-dwarf-ranges unit-info next_cfi \
elfcopy addsections xlate_notes elfrdwrnop \
dwelf_elf_e_machine_string \
- getphdrnum leb128
+ getphdrnum leb128 read_unaligned
asm_TESTS = asm-tst1 asm-tst2 asm-tst3 asm-tst4 asm-tst5 \
asm-tst6 asm-tst7 asm-tst8 asm-tst9
@@ -186,7 +186,7 @@ TESTS = run-arextract.sh run-arsymtest.sh run-ar.sh newfile test-nlist \
run-disasm-riscv64.sh \
run-pt_gnu_prop-tests.sh \
run-getphdrnum.sh run-test-includes.sh \
- leb128
+ leb128 read_unaligned
if !BIARCH
export ELFUTILS_DISABLE_BIARCH = 1
@@ -696,6 +696,7 @@ elfrdwrnop_LDADD = $(libelf)
dwelf_elf_e_machine_string_LDADD = $(libelf) $(libdw)
getphdrnum_LDADD = $(libelf) $(libdw)
leb128_LDADD = $(libelf) $(libdw)
+read_unaligned_LDADD = $(libelf) $(libdw)
# We want to test the libelf header against the system elf.h header.
# Don't include any -I CPPFLAGS. Except when we install our own elf.h.