summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-04-09 22:38:07 +0200
committerMark Wielaard <mjw@redhat.com>2014-04-15 14:19:55 +0200
commitf7cdc74ed34adc539186385342d99b357c3dbb6b (patch)
treefd1e9457baa0c261a87cae57f5d2c22f25a15b86 /tests/Makefile.am
parent110c273d35515ebcfba0c88ad70dbcd5548b0d3c (diff)
downloadelfutils-f7cdc74ed34adc539186385342d99b357c3dbb6b.tar.gz
readelf: Read the decompressed data when processing .zdebug DWARF sections.
readelf uses libdw to open the Dwarf and read some of the DWARF data. But it also uses its own parsers to display some of the low-level unprocessed data. If the DWARF debug section was zlib compressed it should actually use the decompressed section data from libdw instead of the raw section data. Includes a testcase for those sections that couldn't be properly displayed when compressed before. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4ff032db..44fa5e98 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -128,6 +128,10 @@ if LZMA
TESTS += run-readelf-s.sh run-dwflsyms.sh
endif
+if ZLIB
+TESTS += run-readelf-zdebug.sh
+endif
+
if HAVE_LIBASM
check_PROGRAMS += $(asm_TESTS)
TESTS += $(asm_TESTS)
@@ -269,7 +273,8 @@ EXTRA_DIST = run-arextract.sh run-arsymtest.sh \
testfile-backtrace-demangle.cc \
testfile-backtrace-demangle.core.bz2 \
run-stack-d-test.sh run-stack-i-test.sh \
- testfiledwarfinlines.bz2 testfiledwarfinlines.core.bz2
+ testfiledwarfinlines.bz2 testfiledwarfinlines.core.bz2 \
+ run-readelf-zdebug.sh testfile-debug.bz2 testfile-zdebug.bz2
if USE_VALGRIND
valgrind_cmd='valgrind -q --error-exitcode=1 --run-libc-freeres=no'