summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-01-23 00:56:41 +0100
committerMark Wielaard <mjw@redhat.com>2014-01-30 10:17:15 +0100
commitf48eb6b15fee66e54b488d71738979fc608f25ee (patch)
tree22be2f2780909d8d61df125b29de5f3f60e52e97 /tests/Makefile.am
parent13968d9aa9990d53999b14494ed55c2d68d4ead5 (diff)
downloadelfutils-f48eb6b15fee66e54b488d71738979fc608f25ee.tar.gz
Use -Wformat=2 by default for all files.
This just makes sure that all format strings are given as literals to printf like functions so the compiler can see and check them. Remove all no_Wformat, add -Wformat=2 unconditionally to AM_CFLAGS. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index aa13cfa3..c75e7969 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -355,7 +355,6 @@ get_lines_LDADD = $(libdw) $(libelf) $(libmudflap)
get_files_LDADD = $(libdw) $(libelf) $(libmudflap)
get_aranges_LDADD = $(libdw) $(libelf) $(libmudflap)
allfcts_LDADD = $(libdw) $(libelf) $(libmudflap)
-line2addr_no_Wformat = yes
line2addr_LDADD = $(libdw) $(libmudflap)
addrscopes_LDADD = $(libdw) $(libmudflap)
funcscopes_LDADD = $(libdw) $(libmudflap)