summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2013-03-12 12:02:51 +0100
committerMark Wielaard <mjw@redhat.com>2013-03-12 12:25:25 +0100
commitf1b06b5c1d9837832e74a61e19220ad5670bbc40 (patch)
treee45813697c3f90e13b2677ab526125e6fcc3110a /tests/Makefile.am
parenta58951b183fb3e051870b19c95d8082a3efa3ddb (diff)
downloadelfutils-f1b06b5c1d9837832e74a61e19220ad5670bbc40.tar.gz
libdw and libdwfl srcfiles and srclines fixes for partial_units.
dwfl_getsrclines would always fail, even when lines were found. dwarf_decl_file, and other functions relying on srcfiles or srclines would fail for DIEs in partial_units because stmt_lists on partial_units were ignored. Note that dwz contained a bug which makes things fail in __libdw_formptr for DW_AT_stmt_list with a bogus DW_FORM even with these fixes. https://bugzilla.redhat.com/show_bug.cgi?id=919755 Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 63184f80..a5f7a8c0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -51,7 +51,7 @@ check_PROGRAMS = arextract arsymtest newfile saridx scnnames sectiondump \
dwfl-bug-getmodules dwarf-getmacros addrcfi \
test-flag-nobits dwarf-getstring rerequest_tag \
alldts md5-sha1-test typeiter low_high_pc \
- test-elf_cntl_gelf_getshdr dwflsyms
+ test-elf_cntl_gelf_getshdr dwflsyms dwfllines
asm_TESTS = asm-tst1 asm-tst2 asm-tst3 asm-tst4 asm-tst5 \
asm-tst6 asm-tst7 asm-tst8 asm-tst9
@@ -85,7 +85,7 @@ TESTS = run-arextract.sh run-arsymtest.sh newfile test-nlist \
run-readelf-d.sh run-readelf-gdb_index.sh run-unstrip-n.sh \
run-low_high_pc.sh run-macro-test.sh run-elf_cntl_gelf_getshdr.sh \
run-test-archive64.sh run-readelf-vmcoreinfo.sh \
- run-readelf-mixed-corenote.sh
+ run-readelf-mixed-corenote.sh run-dwfllines.sh
if !STANDALONE
check_PROGRAMS += msg_tst md5-sha1-test
@@ -192,7 +192,8 @@ EXTRA_DIST = run-arextract.sh run-arsymtest.sh \
run-readelf-mixed-corenote.sh testfile63.bz2 testfile64.bz2 \
testfile65.bz2 testfile67.bz2 testfile68.bz2 \
testfile69.core.bz2 testfile69.so.bz2 \
- testfile70.core.bz2 testfile70.exec.bz2
+ testfile70.core.bz2 testfile70.exec.bz2 \
+ run-dwfllines.sh
if USE_VALGRIND
valgrind_cmd="valgrind -q --trace-children=yes --error-exitcode=1 --run-libc-freeres=no"
@@ -300,6 +301,7 @@ typeiter_LDADD = $(libdw) $(libelf) $(libmudflap)
low_high_pc_LDADD = $(libdw) $(libelf) $(libmudflap)
test_elf_cntl_gelf_getshdr_LDADD = $(libelf) $(libmudflap)
dwflsyms_LDADD = $(libdw) $(libelf) $(libmudflap)
+dwfllines_LDADD = $(libdw) $(libelf) $(libmudflap)
if GCOV
check: check-am coverage