summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2013-10-15 23:53:32 +0200
committerMark Wielaard <mjw@redhat.com>2013-10-22 12:49:06 +0200
commitd182974079c7205973ae7885b95216a5b83b6f82 (patch)
tree453f6fa480e420af57f3da9623b989e5343b213c /tests/Makefile.am
parent4f7673f97b5d09db2bc216cc3c46b96e999c15f2 (diff)
downloadelfutils-d182974079c7205973ae7885b95216a5b83b6f82.tar.gz
libdwfl: Don't report and abort on non-file mappings in maps.
proc_maps_report, used for -p or -M, could report modules with names that were not absolute file names (and not the special vdso marker). dwfl_linux_proc_find_elf would abort on such names. This isn't a very nice thing to do in a library. Make sure only real (absolute) file mappings are reported and don't abort when unexpected file names are found, just report failure. Test case with some examples as found in Linux /proc/PID/maps added. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index de98e456..f3c56bff 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -65,7 +65,7 @@ TESTS = run-arextract.sh run-arsymtest.sh newfile test-nlist \
run-strip-test3.sh run-strip-test4.sh run-strip-test5.sh \
run-strip-test6.sh run-strip-test7.sh run-strip-test8.sh \
run-strip-groups.sh run-strip-reloc.sh \
- run-unstrip-test.sh run-unstrip-test2.sh \
+ run-unstrip-test.sh run-unstrip-test2.sh run-unstrip-M.sh \
run-ecp-test.sh run-ecp-test2.sh run-alldts.sh \
run-elflint-test.sh run-elflint-self.sh run-ranlib-test.sh \
run-ranlib-test2.sh run-ranlib-test3.sh run-ranlib-test4.sh \
@@ -125,7 +125,7 @@ EXTRA_DIST = run-arextract.sh run-arsymtest.sh \
run-strip-test7.sh run-strip-test8.sh run-strip-groups.sh \
run-strip-reloc.sh hello_i386.ko.bz2 hello_x86_64.ko.bz2 \
hello_ppc64.ko.bz2 hello_s390.ko.bz2 \
- run-unstrip-test.sh run-unstrip-test2.sh \
+ run-unstrip-test.sh run-unstrip-test2.sh run-unstrip-M.sh\
run-elflint-self.sh run-ranlib-test.sh run-ranlib-test2.sh \
run-ranlib-test3.sh run-ranlib-test4.sh \
run-addrscopes.sh run-strings-test.sh run-funcscopes.sh \