summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2012-12-03 17:01:09 +0100
committerMark Wielaard <mjw@redhat.com>2012-12-03 17:01:09 +0100
commit1d6a435f55ba6ee1568fb6fede6495e37c455cae (patch)
tree4e8bafff9b7a4170f1cbb96b63d6f69154e4e306 /tests/Makefile.am
parentd5784afaf49cd59b9286e766cd9b1cf00cb43553 (diff)
downloadelfutils-1d6a435f55ba6ee1568fb6fede6495e37c455cae.tar.gz
Run valgrind tests with --run-libc-freeres=no.
By default valgrind tries to free up glibc memory at exit by running __libc_freeres (). Unfortunately some older glibc versions have bugs that either crash the test or make valgrind report errors. Since we aren't interested in tracking memory leaks in glibc anyway, just disable it. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6808bd13..8b7b751f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -184,7 +184,7 @@ EXTRA_DIST = run-arextract.sh run-arsymtest.sh \
testfile70.core.bz2 testfile70.exec.bz2
if USE_VALGRIND
-valgrind_cmd="valgrind -q --trace-children=yes --error-exitcode=1"
+valgrind_cmd="valgrind -q --trace-children=yes --error-exitcode=1 --run-libc-freeres=no"
endif
installed_TESTS_ENVIRONMENT = libdir=$(DESTDIR)$(libdir) \