summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-08-15 22:19:26 +0000
committerUlrich Drepper <drepper@redhat.com>2005-08-15 22:19:26 +0000
commite5294612b9ea64b36b9c5d41b497d371d05d5a11 (patch)
tree77c209524144bdefdeeed34853370f9d2c934ddc /src/Makefile.am
parente48c05b6262663024aba80365ebe003b64a3015d (diff)
downloadelfutils-e5294612b9ea64b36b9c5d41b497d371d05d5a11.tar.gz
Correct build programs caused by commit from devel tree.
elf_begin robustification.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 29a537c2..234d1b6f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -38,7 +38,7 @@ native_ld = @native_ld@
base_cpu = @base_cpu@
bin_PROGRAMS = readelf nm size strip ld elflint findtextrel addr2line \
- elfcmp objdump ar ranlib
+ elfcmp objdump ranlib
ld_dsos = libld_elf_i386_pic.a
@@ -67,7 +67,7 @@ libmudflap = -lmudflap
endif
if BUILD_STATIC
-libdw = ../libdw/libdw.a
+libdw = ../libdw/libdw.a $(libelf) $(libebl)
libelf = ../libelf/libelf.a
else
libdw = ../libdw/libdw.so
@@ -95,7 +95,6 @@ findtextrel_LDADD = $(libdw) $(libelf) $(libmudflap)
addr2line_LDADD = $(libdw) $(libmudflap)
elfcmp_LDADD = $(libebl) $(libelf) $(libmudflap) -ldl
objdump_LDADD = $(libebl) $(libelf) $(libeu) $(libmudflap) -ldl
-ar_LDADD = $(libelf) $(libmudflap)
ranlib_LDADD = $(libelf) $(libeu) $(libmudflap)
ldlex.o: ldscript.c