summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2015-05-20 11:52:27 +0200
committerMark Wielaard <mjw@redhat.com>2015-05-27 17:17:51 +0200
commitcd2da6c37b468c7ac66d2edcd83f8bcbaeb793ec (patch)
tree0ffba17e8bcfc5de4372ec5f53690a5679d3fe77 /src/Makefile.am
parent70a504d1e19fe14cf34ab3e7a0179aa421f548e0 (diff)
downloadelfutils-cd2da6c37b468c7ac66d2edcd83f8bcbaeb793ec.tar.gz
addr2line: Add demangler support.
Makes the -C, --demangle option visible and implements it (ignoring the demangle style argument). Adds a new test with sample output. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ab5364fe..58cbe764 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -102,7 +102,7 @@ endif
ld_LDFLAGS = -rdynamic
elflint_LDADD = $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
findtextrel_LDADD = $(libdw) $(libelf) $(argp_LDADD)
-addr2line_LDADD = $(libdw) $(libelf) $(argp_LDADD)
+addr2line_LDADD = $(libdw) $(libelf) $(argp_LDADD) $(demanglelib)
elfcmp_LDADD = $(libebl) $(libelf) $(argp_LDADD) -ldl
objdump_LDADD = $(libasm) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
ranlib_LDADD = libar.a $(libelf) $(libeu) $(argp_LDADD)