summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2015-05-23 17:50:09 +0200
committerMark Wielaard <mjw@redhat.com>2015-05-27 23:04:31 +0200
commit712f3c8930a372345b94270ede67233f94a7263b (patch)
tree1f7596b047dbb02dbfa99acd7651fc7d8f6a2089 /src/Makefile.am
parente69f59c6710c8861c2be95699e6e7806b1de2941 (diff)
downloadelfutils-712f3c8930a372345b94270ede67233f94a7263b.tar.gz
config: Add -Wstack-usage=262144 (256K) warning check.
All library code now builds with this warning and -Werror enabled. Add exceptions for most of the src tools (ldgeneric, readelf, nm, size, strip, elflint, findtextrel, elfcmp objdump, ranlib, ar and unstrip). Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 58cbe764..cd2755b0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -88,6 +88,20 @@ endif
# XXX While the file is not finished, don't warn about this
ldgeneric_no_Wunused = yes
+ldgeneric_no_Wstack_usage = yes
+
+# Bad, bad stack usage...
+readelf_no_Wstack_usage = yes
+nm_no_Wstack_usage = yes
+size_no_Wstack_usage = yes
+strip_no_Wstack_usage = yes
+elflint_no_Wstack_usage = yes
+findtextrel_no_Wstack_usage = yes
+elfcmp_no_Wstack_usage = yes
+objdump_no_Wstack_usage = yes
+ranlib_no_Wstack_usage = yes
+ar_no_Wstack_usage = yes
+unstrip_no_Wstack_usage = yes
readelf_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl
nm_LDADD = $(libdw) $(libebl) $(libelf) $(libeu) $(argp_LDADD) -ldl \