summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2006-07-07 03:43:47 +0000
committerUlrich Drepper <drepper@redhat.com>2006-07-07 03:43:47 +0000
commit28ed895fdc303b2a793506bb1fcdd35d5fd14e70 (patch)
tree1385a2d5f0e844e26990b9da92b784ca73c73000 /src/Makefile.am
parent1d3a64d70c8f2aec1fc3ae26d124823c1ef304a9 (diff)
downloadelfutils-28ed895fdc303b2a793506bb1fcdd35d5fd14e70.tar.gz
merge of 2d5572f10b65f0ac7fdf54361b4dae41ebbd51d0
and fda3a25581b7bfac581504e9e887e9b97f234f86
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 49e01740..604483ab 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -63,6 +63,12 @@ else
noinst_LIBRARIES = libld_elf.a $(ld_dsos)
noinst_PROGRAMS = $(ld_dsos:_pic.a=.so)
endif
+if NEVER
+# We never build this library but we need to get the dependency files
+# of all the linker backends that might be used in a non-generic linker.
+noinst_LIBRARIES += libdummy.a
+libdummy_a_SOURCES = i386_ld.c
+endif
textrel_check = if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
@@ -102,6 +108,7 @@ size_LDADD = $(libelf) $(libeu) $(libmudflap)
strip_LDADD = $(libebl) $(libelf) $(libeu) $(libmudflap) -ldl
ld_LDADD = $(libebl) $(libelf) $(libeu) $(libmudflap) -ldl
if NATIVE_LD
+# -ldl is always needed for libebl.
ld_LDADD += libld_elf.a
endif
ld_LDFLAGS = -rdynamic
@@ -117,9 +124,10 @@ ldlex.o: ldscript.c
ldlex_no_Werror = yes
ldscript.h: ldscript.c
+if NATIVE_LD
# Machine-specific linker code.
-libld_elf_a_SOURCES = $(base_cpu)_ld.c
-
+libld_elf_a_SOURCES := $(base_cpu)_ld.c
+else
libld_elf_i386_pic_a_SOURCES =
am_libld_elf_i386_pic_a_OBJECTS = i386_ld.os
@@ -129,6 +137,7 @@ libld_elf_i386.so: libld_elf_i386_pic.a libld_elf_i386.map
$(libelf) $(libeu) \
-Wl,--version-script,$(srcdir)/libld_elf_i386.map
$(textrel_check)
+endif
%.os: %.c %.o