summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Stone <jistone@redhat.com>2015-10-05 11:04:15 -0700
committerJosh Stone <jistone@redhat.com>2015-10-06 17:50:10 -0700
commitdaee4714ee3761e2d92f764a724e83875a79a3f0 (patch)
tree9c6bab2d7253ea23706f665bd9bf4da0b2b02988 /src/Makefile.am
parent0e3ce39c8f154cb7df7f3a9bf29d347fe9cca036 (diff)
downloadelfutils-daee4714ee3761e2d92f764a724e83875a79a3f0.tar.gz
Improve AM_SILENT_RULES coverage
Note, elfutils does not explicitly enable AM_SILENT_RULES. It's only available starting from automake 1.11, but starting from automake 1.13 silent rules are always generated, defaulting to verbose. $(AM_V_foo) additions should be no-ops on systems that don't support silent rules. To be silent, use "./configure --enable-silent-rules" or "make V=0". Signed-off-by: Josh Stone <jistone@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cd2755b0..afb38fc0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -138,7 +138,7 @@ am_libld_elf_i386_pic_a_OBJECTS = i386_ld.os
libld_elf_i386_so_SOURCES =
libld_elf_i386.so: libld_elf_i386_pic.a libld_elf_i386.map
- $(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
+ $(AM_V_CCLD)$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
$(libelf) $(libeu) \
-Wl,--version-script,$(srcdir)/libld_elf_i386.map
@$(textrel_check)
@@ -147,7 +147,7 @@ endif
# Special rule to make it possible to define libld_elf_a_SOURCES as we do.
# Otherwise make would complain.
.deps/none_ld.Po: none_ld.os
- -:
+ @-:
installcheck-binPROGRAMS: $(bin_PROGRAMS)
@@ -172,11 +172,11 @@ MAINTAINERCLEANFILES = ldlex.c ldscript.c ldscript.h
make-debug-archive: $(srcdir)/make-debug-archive.in
- UNSTRIP=$(bindir)/`echo unstrip | sed '$(transform)'`; \
+ $(AM_V_GEN)UNSTRIP=$(bindir)/`echo unstrip | sed '$(transform)'`; \
AR=$(bindir)/`echo ar | sed '$(transform)'`; \
sed -e "s,[@]UNSTRIP[@],$$UNSTRIP,g" -e "s,[@]AR[@],$$AR,g" \
-e "s%[@]PACKAGE_NAME[@]%$(PACKAGE_NAME)%g" \
-e "s%[@]PACKAGE_VERSION[@]%$(PACKAGE_VERSION)%g" \
$(srcdir)/make-debug-archive.in > $@.new
- chmod +x $@.new
- mv -f $@.new $@
+ $(AM_V_at)chmod +x $@.new
+ $(AM_V_at)mv -f $@.new $@