summaryrefslogtreecommitdiff
path: root/libebl/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-05-19 16:52:56 +0200
committerMark Wielaard <mjw@redhat.com>2014-05-19 22:04:24 +0200
commit028d0ab0cc1cb5f96ee48feef966b7d8d56c6a8e (patch)
treea8217d678cede635782d0fe33413a3dc3ae206af /libebl/Makefile.am
parent85482fc073442a056e0e3663eb454fa76d883271 (diff)
downloadelfutils-028d0ab0cc1cb5f96ee48feef966b7d8d56c6a8e.tar.gz
backends: Add ebl_check_reloc_target_type.
And implement for arm and ia64. Both have special section types that are valid targets for a reloc. Both refer to unwind data. elflint now just calls ebl_check_reloc_target_type instead of hard coding the expected section types. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'libebl/Makefile.am')
-rw-r--r--libebl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libebl/Makefile.am b/libebl/Makefile.am
index 916af72a..ec4477b7 100644
--- a/libebl/Makefile.am
+++ b/libebl/Makefile.am
@@ -55,7 +55,7 @@ gen_SOURCES = eblopenbackend.c eblclosebackend.c eblstrtab.c \
eblsysvhashentrysize.c eblauxvinfo.c eblcheckobjattr.c \
ebl_check_special_section.c ebl_syscall_abi.c eblabicfi.c \
eblstother.c eblinitreg.c ebldwarftoregno.c eblnormalizepc.c \
- eblunwind.c eblresolvesym.c
+ eblunwind.c eblresolvesym.c eblcheckreloctargettype.c
libebl_a_SOURCES = $(gen_SOURCES)