summaryrefslogtreecommitdiff
path: root/libdwelf/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2014-04-30 23:00:40 +0200
committerMark Wielaard <mjw@redhat.com>2014-05-01 13:51:31 +0200
commitd81d32d2a4f92355e4c677b578147dfe819251b9 (patch)
tree79c9bf17a4334d86c220676fc8c6b54b1dacee34 /libdwelf/Makefile.am
parent920f03dcd3a6dd46b3d88c45be8dbfa0adc780dd (diff)
downloadelfutils-d81d32d2a4f92355e4c677b578147dfe819251b9.tar.gz
libdwelf: Add dwelf_elf_gnu_build_id.
Move internal function __libdwfl_find_build_id to libdwelf and use it to add a public dwelf_elf_gnu_build_id function to extract the NT_GNU_BUILD_ID from an ELF file using either the shdrs or phdrs. Adjust internal callers and add a testcase. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'libdwelf/Makefile.am')
-rw-r--r--libdwelf/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libdwelf/Makefile.am b/libdwelf/Makefile.am
index 1ca3a5cd..cd4b7ddf 100644
--- a/libdwelf/Makefile.am
+++ b/libdwelf/Makefile.am
@@ -30,7 +30,8 @@
## not, see <http://www.gnu.org/licenses/>.
##
include $(top_srcdir)/config/eu.am
-AM_CPPFLAGS += -I$(srcdir)/../libelf -I$(srcdir)/../libdw
+AM_CPPFLAGS += -I$(srcdir)/../libelf -I$(srcdir)/../libdw \
+ -I$(srcdir)/../libdwfl -I$(srcdir)/../libebl
VERSION = 1
noinst_LIBRARIES = libdwelf.a libdwelf_pic.a
@@ -38,7 +39,8 @@ noinst_LIBRARIES = libdwelf.a libdwelf_pic.a
pkginclude_HEADERS = libdwelf.h
noinst_HEADERS = libdwelfP.h
-libdwelf_a_SOURCES = dwelf_elf_gnu_debuglink.c dwelf_dwarf_gnu_debugaltlink.c
+libdwelf_a_SOURCES = dwelf_elf_gnu_debuglink.c dwelf_dwarf_gnu_debugaltlink.c \
+ dwelf_elf_gnu_build_id.c
libdwelf = $(libdw)