summaryrefslogtreecommitdiff
path: root/libdw/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2009-01-05 23:59:32 -0800
committerRoland McGrath <roland@redhat.com>2009-01-05 23:59:32 -0800
commitbca43152aa0bcb31b9442c407bf2b86379761c50 (patch)
tree50751cde17184a37e7439b6dde15dbb48a4d1fea /libdw/Makefile.am
parent92287fdf5b21438a3aa3d7094527b5cf870d1af6 (diff)
downloadelfutils-bca43152aa0bcb31b9442c407bf2b86379761c50.tar.gz
libdwfl automagic decompression support
Diffstat (limited to 'libdw/Makefile.am')
-rw-r--r--libdw/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libdw/Makefile.am b/libdw/Makefile.am
index 69ce526c..8649395a 100644
--- a/libdw/Makefile.am
+++ b/libdw/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to create Makefile.in
##
-## Copyright (C) 2002, 2003, 2004, 2005, 2006, 2007, 2008 Red Hat, Inc.
+## Copyright (C) 2002-2009 Red Hat, Inc.
## This file is part of Red Hat elfutils.
##
## Red Hat elfutils is free software; you can redistribute it and/or modify
@@ -92,7 +92,7 @@ am_libdw_pic_a_OBJECTS = $(libdw_a_SOURCES:.c=.os)
libdw_so_SOURCES =
libdw.so: $(srcdir)/libdw.map libdw_pic.a \
../libdwfl/libdwfl_pic.a ../libebl/libebl.a \
- ../libelf/libelf.so
+ ../libelf/libelf.so $(zip_LIBS)
# The rpath is necessary for libebl because its $ORIGIN use will
# not fly in a setuid executable that links in libdw.
$(LINK) -shared -o $@ -Wl,--soname,$@.$(VERSION),-z,defs \