summaryrefslogtreecommitdiff
path: root/libasm/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2008-12-04 06:28:06 +0000
committerRoland McGrath <roland@redhat.com>2008-12-04 06:28:06 +0000
commit12af5a2882bf23f3f2b55d78ef2ea568bac120de (patch)
tree686a3f6ae8733a2a7bafb73228aec88a02071098 /libasm/Makefile.am
parent02f66452635df3d01f7e57845c3362ab828e3d89 (diff)
downloadelfutils-12af5a2882bf23f3f2b55d78ef2ea568bac120de.tar.gz
merge of '4c5dbb5e116d9a9c7f9014a3dcbabba8e7d89327'
and 'fddaff07d3c095a3d26f41fe7a7da147c024bd96'
Diffstat (limited to 'libasm/Makefile.am')
-rw-r--r--libasm/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
index bd5779e8..62b5ee29 100644
--- a/libasm/Makefile.am
+++ b/libasm/Makefile.am
@@ -65,12 +65,17 @@ if !MUDFLAP
libasm_pic_a_SOURCES =
am_libasm_pic_a_OBJECTS = $(libasm_a_SOURCES:.c=.os)
+libasm_so_LDLIBS =
+if USE_TLS
+libasm_so_LDLIBS += -lpthread
+endif
+
libasm_so_SOURCES =
libasm.so: libasm_pic.a libasm.map
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
-Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
-Wl,--soname,$@.$(VERSION) \
- ../libebl/libebl.a ../libelf/libelf.so
+ ../libebl/libebl.a ../libelf/libelf.so $(libasm_so_LDLIBS)
if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)