summaryrefslogtreecommitdiff
path: root/libasm/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2008-12-04 05:58:16 +0000
committerUlrich Drepper <drepper@redhat.com>2008-12-04 05:58:16 +0000
commit02f66452635df3d01f7e57845c3362ab828e3d89 (patch)
tree24b5255577524d60a33f79596fa1505379d96901 /libasm/Makefile.am
parent593798821113c57fe10f1fdf6593658d99d05ca9 (diff)
downloadelfutils-02f66452635df3d01f7e57845c3362ab828e3d89.tar.gz
propagate from branch 'com.redhat.elfutils.roland.pending.libelf-threads' (head fc97c9c202b5d7d7699a3b1d5c53007a2ef37bb1)
to branch 'com.redhat.elfutils' (head 67cccb9bfffc1a7fe3d8d355a2d9b6d0e489ff81)
Diffstat (limited to 'libasm/Makefile.am')
-rw-r--r--libasm/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
index 62b5ee29..bd5779e8 100644
--- a/libasm/Makefile.am
+++ b/libasm/Makefile.am
@@ -65,17 +65,12 @@ if !MUDFLAP
libasm_pic_a_SOURCES =
am_libasm_pic_a_OBJECTS = $(libasm_a_SOURCES:.c=.os)
-libasm_so_LDLIBS =
-if USE_TLS
-libasm_so_LDLIBS += -lpthread
-endif
-
libasm_so_SOURCES =
libasm.so: libasm_pic.a libasm.map
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
-Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
-Wl,--soname,$@.$(VERSION) \
- ../libebl/libebl.a ../libelf/libelf.so $(libasm_so_LDLIBS)
+ ../libebl/libebl.a ../libelf/libelf.so
if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)