summaryrefslogtreecommitdiff
path: root/elfutils.spec
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2009-04-24 20:12:58 +0000
committerDmitry V. Levin <ldv@altlinux.org>2009-04-24 20:12:58 +0000
commit5a4cef9b6c2899944308fdb8f78559fc0df766cc (patch)
treea2369e429320b9de36cc73d858273b8eedaf99d5 /elfutils.spec
parentd431016d60829733e5cf287f03bd190ebcb013e5 (diff)
downloadelfutils-5a4cef9b6c2899944308fdb8f78559fc0df766cc.tar.gz
0.141-10.141-1
- Update to 0.141 - libebl: sparc backend fixes (#490585) some more arm backend support - libdwfl: fix dwfl_module_build_id for prelinked DSO case (#489439) fixes in core file support (#494858) dwfl_module_getsym interface improved for non-address symbols - eu-strip: fix infinite loop on strange inputs with -f - eu-addr2line: take -j/--section=NAME option for binutils compatibility (same effect as '(NAME)0x123' syntax already supported) - Resolves: RHBZ #495213, RHBZ #465872, RHBZ #470055, RHBZ #484623
Diffstat (limited to 'elfutils.spec')
-rw-r--r--elfutils.spec87
1 files changed, 69 insertions, 18 deletions
diff --git a/elfutils.spec b/elfutils.spec
index d2d34309..7b51df8e 100644
--- a/elfutils.spec
+++ b/elfutils.spec
@@ -1,5 +1,5 @@
-%define eu_version 0.137
-%define eu_release 3
+%define eu_version 0.141
+%define eu_release 1
%if %{?_with_compat:1}%{!?_with_compat:0}
%define compat 1
@@ -27,15 +27,14 @@ Version: %{eu_version}
%if !%{compat}
Release: %{eu_release}%{?dist}
%else
-Release: 0.%{eu_release}
+Release: 0.%{eu_release}.1
%endif
License: GPLv2 with exceptions
Group: Development/Tools
URL: https://fedorahosted.org/elfutils/
-Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.gz
-Patch1: elfutils-portability.patch
-Patch2: elfutils-robustify.patch
-Patch3: elfutils-0.137-fixes.patch
+Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
+Patch1: elfutils-robustify.patch
+Patch2: elfutils-portability.patch
Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
Requires: elfutils-libs-%{_arch} = %{version}-%{release}
@@ -51,6 +50,19 @@ BuildRequires: glibc-headers >= 2.3.4-11
BuildRequires: gcc >= 3.2
%endif
+%define use_zlib 0
+%if 0%{?fedora} >= 5
+%define use_zlib 1
+%endif
+%if 0%{?rhel} >= 5
+%define use_zlib 1
+%endif
+
+%if %{use_zlib}
+BuildRequires: zlib-devel >= 1.2.2.3
+BuildRequires: bzip2-devel
+%endif
+
%define _gnu %{nil}
%define _program_prefix eu-
@@ -143,21 +155,19 @@ for libelf.
%prep
%setup -q
-%if !0%{?scanf_has_m}
-sed -i.scanf-m -e 's/%m/%a/' tests/line2addr.c
-%endif
+%patch1 -p1 -b .robustify
%if %{compat}
-%patch1 -p1 -b .portability
+%patch2 -p1 -b .portability
sleep 1
find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
sleep 1
find . \( -name configure -o -name config.h.in \) -print | xargs touch
+%else
+%if !0%{?scanf_has_m}
+sed -i.scanf-m -e 's/%m/%a/g' src/addr2line.c tests/line2addr.c
+%endif
%endif
-
-%patch2 -p1 -b .robustify
-
-%patch3 -p1 -b .fixes
find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
@@ -184,9 +194,9 @@ chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
# XXX Nuke unpackaged files
-{ cd ${RPM_BUILD_ROOT}
- rm -f .%{_bindir}/eu-ld
-}
+(cd ${RPM_BUILD_ROOT}
+ rm -f .%{_bindir}/eu-ld
+)
%check
make -s check
@@ -239,6 +249,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_includedir}/elfutils/libebl.h
%{_includedir}/elfutils/libdw.h
%{_includedir}/elfutils/libdwfl.h
+%{_includedir}/elfutils/version.h
%{_libdir}/libebl.a
%{_libdir}/libasm.so
%{_libdir}/libdw.so
@@ -265,6 +276,46 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.a
%changelog
+* Thu Apr 23 2009 Roland McGrath <roland@redhat.com> - 0.141-1
+- Update to 0.141
+ - libebl: sparc backend fixes (#490585)
+ some more arm backend support
+ - libdwfl: fix dwfl_module_build_id for prelinked DSO case (#489439)
+ fixes in core file support (#494858)
+ dwfl_module_getsym interface improved for non-address symbols
+ - eu-strip: fix infinite loop on strange inputs with -f
+ - eu-addr2line: take -j/--section=NAME option for binutils compatibility
+ (same effect as '(NAME)0x123' syntax already supported)
+- Resolves: RHBZ #495213, RHBZ #465872, RHBZ #470055, RHBZ #484623
+
+* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.140-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sun Feb 15 2009 Roland McGrath <roland@redhat.com> - 0.140-1
+- Update to 0.140
+ - libelf: Fix regression in creation of section header. (#484946)
+
+* Fri Jan 23 2009 Roland McGrath <roland@redhat.com> - 0.139-1
+- Update to 0.139
+ - libcpu: Add Intel SSE4 disassembler support
+ - readelf: Implement call frame information and exception handling dumping.
+ Add -e option. Enable it implicitly for -a.
+ - elflint: Check PT_GNU_EH_FRAME program header entry.
+ - libdwfl: Support automatic gzip/bzip2 decompression of ELF files. (#472136)
+
+* Thu Jan 1 2009 Roland McGrath <roland@redhat.com> - 0.138-2
+- Fix libelf regression.
+
+* Wed Dec 31 2008 Roland McGrath <roland@redhat.com> - 0.138-1
+- Update to 0.138
+ - Install <elfutils/version.h> header file for applications to use in
+ source version compatibility checks.
+ - libebl: backend fixes for i386 TLS relocs; backend support for NT_386_IOPERM
+ - libcpu: disassembler fixes (#469739)
+ - libdwfl: bug fixes (#465878)
+ - libelf: bug fixes
+ - eu-nm: bug fixes for handling corrupt input files (#476136)
+
* Wed Oct 1 2008 Roland McGrath <roland@redhat.com> - 0.137-3
- fix libdwfl regression (#462689)