summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2008-12-16 17:03:03 -0800
committerRoland McGrath <roland@redhat.com>2008-12-16 17:03:03 -0800
commitfbc7245df72ce0142f0a21fa0f4f88c97278bf60 (patch)
treeb2f5149a5704b490d56849799f3eb85de2250057 /configure.ac
parent45d7b29b1bf7b53ab1164ea3b58529c39d32b4b2 (diff)
downloadelfutils-fbc7245df72ce0142f0a21fa0f4f88c97278bf60.tar.gz
Install elfutils/version.h header for library compatibility checking.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2723046e..f2ddbaf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,4 +229,15 @@ dnl Appended to the config.h file.
dnl We hide all kinds of configuration magic in lib/eu-config.h.
AH_BOTTOM([#include <eu-config.h>])
+dnl Version compatibility header.
+AC_CONFIG_FILES([version.h:config/version.h.in])
+AC_SUBST([eu_version])
+case $PACKAGE_VERSION in
+0.???) eu_version=${PACKAGE_VERSION#0.} ;;
+?.???) eu_version=${PACKAGE_VERSION/./} ;;
+?.??) eu_version=${PACKAGE_VERSION/./}0 ;;
+?.?) eu_version=${PACKAGE_VERSION/./}00 ;;
+*) AC_MSG_ERROR([confused by version number '$PACKAGE_VERSION']) ;;
+esac
+
AC_OUTPUT