summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2020-07-18 01:53:29 +0200
committerMark Wielaard <mark@klomp.org>2020-07-22 15:05:46 +0200
commitad7036f15ef85e9b69015c76802509e9d96856bc (patch)
treea9dff73143aabe606db6c5cf430a3901421f0f85 /configure.ac
parent49c200b7c7731d1ca12b465c20afa4c1475e671c (diff)
downloadelfutils-ad7036f15ef85e9b69015c76802509e9d96856bc.tar.gz
configure.ac: Set -DBAD_FTS=1 also for CXXFLAGS.
debuginfod.cxx checks whether or not BAD_FTS is defined. This only matters on old 32bit arches. Signed-off-by: Mark Wielaard <mark@klomp.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6f04d269..e2f213ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,7 +261,8 @@ dnl check it before including config.h (which might define _FILE_OFFSET_BITS).
AC_CACHE_CHECK([whether fts.h is bad when included (with LFS)], ac_cv_bad_fts,
[AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <fts.h>]])],
ac_cv_bad_fts=no, ac_cv_bad_fts=yes)])
-AS_IF([test "x$ac_cv_bad_fts" = "xyes"], [CFLAGS="$CFLAGS -DBAD_FTS=1"])
+AS_IF([test "x$ac_cv_bad_fts" = "xyes"],
+ [CFLAGS="$CFLAGS -DBAD_FTS=1" CXXFLAGS="$CXXFLAGS -DBAD_FTS=1"])
# See if we can add -D_FORTIFY_SOURCE=2. Don't do it if it is already
# (differently) defined or if it generates warnings/errors because we