summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoland McGrath <roland@hack.frob.com>2011-10-08 15:14:30 -0700
committerRoland McGrath <roland@hack.frob.com>2011-10-08 15:14:30 -0700
commite9bf1d30e7fd35cbe11c6586500cab11a1d91918 (patch)
tree0b3393144748e8b68326fd8da8aad651b7044339 /configure.ac
parent8f3002e2a7a0aa83843d8b4c5f307d6418f92490 (diff)
downloadelfutils-e9bf1d30e7fd35cbe11c6586500cab11a1d91918.tar.gz
Use POSIX.2 shell features in eu_version calculation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cf3f6d68..826e6441 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,7 +255,7 @@ AC_SUBST([eu_version])
# 1.234<whatever> -> 1234<whatever>
case "$PACKAGE_VERSION" in
-[[0-9]].*) eu_version="${PACKAGE_VERSION/./}" ;;
+[[0-9]].*) eu_version=`echo "$PACKAGE_VERSION" | sed 's@\.@@'` ;;
*) AC_MSG_ERROR([confused by version number '$PACKAGE_VERSION']) ;;
esac
case "$eu_version" in
@@ -284,6 +284,6 @@ case "$eu_version" in
esac
# Round up to the next release API (x.y) version.
-[eu_version=$[($eu_version + 999) / 1000]]
+eu_version=$(( (eu_version + 999) / 1000 ))
AC_OUTPUT