summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Kratochvil <jan.kratochvil@redhat.com>2013-05-30 14:37:38 +0200
committerJan Kratochvil <jan.kratochvil@redhat.com>2013-11-07 21:39:00 +0100
commit0b867460075c9f02cb305abc91a0e12b90017583 (patch)
tree28f799db9b0eef70d0b4b5e81163b2fc62903470 /configure.ac
parent22f867adcc1258aeb88560fa8591ef071353bb22 (diff)
downloadelfutils-0b867460075c9f02cb305abc91a0e12b90017583.tar.gz
Unwinder for x86*.
Signed-off-by: Jan Kratochvil <jan.kratochvil@redhat.com> Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 03d5756f..99b74ae5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,4 +326,15 @@ esac
# Round up to the next release API (x.y) version.
eu_version=$(( (eu_version + 999) / 1000 ))
+AC_CHECK_SIZEOF(long)
+
+# On a 64-bit host where can can use $CC -m32, we'll run two sets of tests.
+# Likewise in a 32-bit build on a host where $CC -m64 works.
+utrace_BIARCH
+# `$utrace_biarch' will be `-m64' even on an uniarch i386 machine.
+AS_IF([test $utrace_cv_cc_biarch = yes],
+ [CC_BIARCH="$CC $utrace_biarch"],
+ [CC_BIARCH="$CC"])
+AC_SUBST([CC_BIARCH])
+
AC_OUTPUT