summaryrefslogtreecommitdiff
path: root/backends/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2022-06-01 13:14:27 +0200
committerMark Wielaard <mark@klomp.org>2022-06-06 13:33:32 +0200
commit1daec75e0ff5313eec93b60f54fcb5ddc9d2ad28 (patch)
treec1c5e1eecc56c164179f00cf5c8876c68ea3561f /backends/Makefile.am
parentc1e2bff661d7b31ca507e5a69d7dd877e9f47c7f (diff)
downloadelfutils-1daec75e0ff5313eec93b60f54fcb5ddc9d2ad28.tar.gz
Arm Ehdr flag printing
Arm needs to decode flags and I modeled it after the binutils code. The same messages are printed. Given the requirement of the interface and the ABIs the current version of the callback function isn't sufficient unless one wants to create a stateful interface. The problem is that most flags need to be interpreted in the context of the ABI version. So I changed the API to also pass the original flag value. This shouldn't be a problem because there are no users yet. There is also a bug in ebl_machine_flag_name. When copying the string provided by the callback cp is moved past the NUL byte. It should move to the NUL byte. Otherwise one cannot anything but the first added flag description. Finally some cosmetic changes (space after each comma in the output). Signed-off-by: Mark Wielaard <mark@klomp.org>
Diffstat (limited to 'backends/Makefile.am')
-rw-r--r--backends/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/backends/Makefile.am b/backends/Makefile.am
index 62916c9c..9566377f 100644
--- a/backends/Makefile.am
+++ b/backends/Makefile.am
@@ -56,7 +56,8 @@ alpha_SRCS = alpha_init.c alpha_symbol.c alpha_retval.c alpha_regs.c \
alpha_corenote.c alpha_auxv.c
arm_SRCS = arm_init.c arm_symbol.c arm_regs.c arm_corenote.c \
- arm_auxv.c arm_attrs.c arm_retval.c arm_cfi.c arm_initreg.c
+ arm_auxv.c arm_attrs.c arm_retval.c arm_cfi.c arm_initreg.c \
+ arm_machineflagname.c
aarch64_SRCS = aarch64_init.c aarch64_regs.c aarch64_symbol.c \
aarch64_corenote.c aarch64_retval.c aarch64_cfi.c \