summaryrefslogtreecommitdiff
path: root/backends/Makefile.am
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-04-20 14:41:35 +0200
committerMark Wielaard <mark@klomp.org>2017-04-25 14:28:59 +0200
commitf4d706ff90b91d252b7dd00cdffab73529eff1b9 (patch)
treeb428da06797ec4e0ae968cc5d33847740ace7925 /backends/Makefile.am
parentc832466bbb9181f7ed997357df02a33ad13f3f22 (diff)
downloadelfutils-f4d706ff90b91d252b7dd00cdffab73529eff1b9.tar.gz
Add frame pointer unwinding for aarch64mjw/fp-unwind
If we don't find any debug information for a given frame, we usually cannot unwind any further. However, the binary in question might have been compiled with frame pointers, in which case we can look up the well known frame pointer locations in the stack snapshot and use them to bridge the frames without debug information. Signed-off-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'backends/Makefile.am')
-rw-r--r--backends/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/backends/Makefile.am b/backends/Makefile.am
index 22eb6ac6..ff80a82c 100644
--- a/backends/Makefile.am
+++ b/backends/Makefile.am
@@ -80,7 +80,7 @@ am_libebl_arm_pic_a_OBJECTS = $(arm_SRCS:.c=.os)
aarch64_SRCS = aarch64_init.c aarch64_regs.c aarch64_symbol.c \
aarch64_corenote.c aarch64_retval.c aarch64_cfi.c \
- aarch64_initreg.c
+ aarch64_initreg.c aarch64_unwind.c
libebl_aarch64_pic_a_SOURCES = $(aarch64_SRCS)
am_libebl_aarch64_pic_a_OBJECTS = $(aarch64_SRCS:.c=.os)