summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2012-10-01 16:14:12 +0200
committerMark Wielaard <mjw@redhat.com>2012-10-01 17:33:14 +0200
commite3e3ee261e0d2f8716b5011ca5fcfc88766146f5 (patch)
tree4b096a1a1dea2deafbd2656303569f99a50381fb /Makefile.am
parentea45ac8e1d937b727122a0a286ad9b37f02fe0a2 (diff)
downloadelfutils-e3e3ee261e0d2f8716b5011ca5fcfc88766146f5.tar.gz
Add configure --enable-valgrind option to run all tests under valgrind.
Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 305bbfcb..e8339898 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,8 +32,10 @@ EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
# Make sure the test install uses lib64 when $LIB will yield lib64.
# Make sure the test build uses the same compiler, which on e.g. ppc64
# determines which platform we are actually testing.
+# Run all tests under valgrind.
DISTCHECK_CONFIGURE_FLAGS = \
--libdir=`echo $(libdir) | sed "s,^$(exec_prefix),$$dc_install_base,"`\
+ --enable-valgrind \
CC="$(CC)"
distcheck-hook: