summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOmar Sandoval <osandov@fb.com>2019-08-26 10:51:46 -0700
committerMark Wielaard <mark@klomp.org>2019-08-29 13:30:30 +0200
commit4f937e24dc7ad1820fc7c99a6dd6422657f14666 (patch)
treee7f08c104a0c679eb49b1071fee6e35eda38a993 /Makefile.am
parentab415cea199547ee06c50aa82eebe9c58307576f (diff)
downloadelfutils-4f937e24dc7ad1820fc7c99a6dd6422657f14666.tar.gz
Don't use dlopen() for libebl modules
Currently, architecture-specific code for libebl exists in separate libebl_$ARCH.so libraries which libebl loads with dlopen() at runtime. This makes it impossible to have standalone, statically-linked binaries which use libdwfl if they depend on any architecture-specific functionality. Additionally, when these libraries cannot be found, the failure modes are non-obvious. So, let's get rid of libebl_$arch.so and move it all into libdw.so/libdw.a, which simplifies things considerably. Signed-off-by: Omar Sandoval <osandov@fb.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f2ece49..52f64fc9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,8 @@ AM_MAKEFLAGS = --no-print-directory
pkginclude_HEADERS = version.h
-SUBDIRS = config m4 lib libelf libebl libdwelf libdwfl libdw libcpu libasm \
- backends src po doc tests
+SUBDIRS = config m4 lib libelf libcpu backends libebl libdwelf libdwfl libdw \
+ libasm src po doc tests
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
COPYING COPYING-GPLV2 COPYING-LGPLV3