summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2012-06-13 15:29:13 -0400
committerTheodore Ts'o <tytso@mit.edu>2012-06-13 16:06:44 -0400
commitc1986ecb6fc68427db7579d409929939117e45ff (patch)
tree8cb42a4ced5d8eab9d26408c383f537c71974b4e /configure.in
parent8f00911a21f4e95de84c60e09cc4df173e5b6701 (diff)
downloade2fsprogs-c1986ecb6fc68427db7579d409929939117e45ff.tar.gz
Fix blhc (Build Log Hardening Check) warnings
The Build Log Hardening Check is a debian tool which scans the output of a package build making sure that the security hardening flags are used when compiling and linking all of binaries in a package. For the most part we were passing CFLAGS, CPPFLAGS, and LDFLAGS down to the compiler and link commands, but there there were one or two exceptions. In addition, there where a few places in "make install" where the V=1 option was not being honored, which triggered blhc warnings since it couldn't analyze those commands. The e2fsck.static was the only binary that was not getting built and packaged with the hardening flags, but I've fixed all of the blhc warnings so in the future it will be obvious if we regress. Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index aa4c777b..7373e8e9 100644
--- a/configure.in
+++ b/configure.in
@@ -212,18 +212,22 @@ if test "$enableval" = "no"
then
AC_MSG_RESULT([Disabling verbose make commands])
E=@echo
+ ES=echo
Q=@
else
AC_MSG_RESULT([Enabling verbose make commands])
E=@\\#
+ ES=\\#
Q=
fi
,
AC_MSG_RESULT([Disabling verbose make commands])
E=@echo
+ES=echo
Q=@
)
AC_SUBST(E)
+AC_SUBST(ES)
AC_SUBST(Q)
dnl
dnl handle --enable-compression
@@ -1230,7 +1234,7 @@ dnl
dnl Build CFLAGS
dnl
if test $cross_compiling = no; then
- BUILD_CFLAGS="$CFLAGS"
+ BUILD_CFLAGS="$CFLAGS $CPPFLAGS"
BUILD_LDFLAGS="$LDFLAGS"
else
BUILD_CFLAGS=