summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcsilvers <csilvers@01de4be4-8c4a-0410-9132-4925637da917>2008-05-13 01:49:15 +0000
committercsilvers <csilvers@01de4be4-8c4a-0410-9132-4925637da917>2008-05-13 01:49:15 +0000
commit06601d6a0f32c0a26f3764485c2047b8b3a72023 (patch)
tree1088e1d226dd0431c16e633b0f4f8938b93b30f2 /configure.ac
parent5202fa23350eb5d6117eb1041807219c80651fc9 (diff)
downloaddistcc-06601d6a0f32c0a26f3764485c2047b8b3a72023.tar.gz
In the non-included popt case, POPT_INCLUDES was the empty string,
leading to a compile command that had -I"" in it. Who knows what that means? Now the -I is part of POPT_INCLUDES, so when it's absent we don't add anything to CPPFLAGS. Tested on a machine where POPT_INCLUDES is not empty and one where it is. Reviewed by klarlund@google.com git-svn-id: http://distcc.googlecode.com/svn/trunk@207 01de4be4-8c4a-0410-9132-4925637da917
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cf76dbd..dc984a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,10 +326,11 @@ then
AC_MSG_RESULT($srcdir/popt)
# popt_OBJS gets appended to distccd object list
BUILD_POPT='$(popt_OBJS)'
- POPT_INCLUDES="$srcdir/popt"
+ POPT_INCLUDES='-I"$(srcdir)/popt"'
else
LIBS="$LIBS -lpopt"
AC_MSG_RESULT(no)
+ POPT_INCLUDES=''
fi