summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfergus.henderson <fergushenderson@users.noreply.github.com>2012-02-06 19:58:07 +0000
committerfergus.henderson <fergushenderson@users.noreply.github.com>2012-02-06 19:58:07 +0000
commitd9a17c699868241ad5867e4c0a96eff4578ac4b9 (patch)
treed6971aa48979663ec0f72b3810e58b6a5f1ede74 /configure.ac
parentcb1bb08301efcd81aa51bbf827ceef8081e21d3f (diff)
downloaddistcc-git-d9a17c699868241ad5867e4c0a96eff4578ac4b9.tar.gz
Apply patch for issue 87 <http://code.google.com/p/distcc/issues/detail?id=87>:
Only undefine _FORTIFY_SOURCE when building with -Werror.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0e08eea..a7041c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -189,6 +189,12 @@ then
if test x"$enable_Werror" != xno
then
WERROR_CFLAGS="-Werror"
+ # -Wp,-U_FORTIFY_SOURCE is to turn off _FORTIFY_SOURCE on systems where
+ # it's in the Python Makefile (and hence inherited by us).
+ # -Werror -D_FORTIFY_SOURCE gives compiler errors for some distcc routines that
+ # ignore the return value from libc functions (like getcwd).
+ # That would cause this code to not compile, which is no good.
+ PYTHON_CFLAGS="-Wp,-U_FORTIFY_SOURCE"
fi
# Additional flags for compiling Python extension modules.
@@ -197,13 +203,8 @@ then
# pointer), and -Wwrite-strings, which just had too many false
# positives (for Python 2.2, anyway; looks like these may be fixed
# in Python 2.5).
- # -Wp,-U_FORTIFY_SOURCE is to turn off _FORTIFY_SOURCE on systems where
- # it's in the Python Makefile (and hence inherited by us).
- # _FORTIFY_SOURCE gives compiler errors for some distcc routines that
- # ignore the return value from libc functions (like getcwd).
- # That would cause this code to not compile, which is no good.
- PYTHON_CFLAGS="-Wno-missing-prototypes -Wno-missing-declarations \
--Wno-write-strings -Wp,-U_FORTIFY_SOURCE"
+ PYTHON_CFLAGS="$PYTHON_CFLAGS -Wno-missing-prototypes -Wno-missing-declarations \
+-Wno-write-strings"
# For popt/*.c, we disable unused variable warnings.
POPT_CFLAGS="-Wno-unused"