summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Silverstein <csilvers@khanacademy.org>2008-05-15 19:39:12 +0000
committerCraig Silverstein <csilvers@khanacademy.org>2008-05-15 19:39:12 +0000
commitb62a519f6c1436224385f956015c024f71841b70 (patch)
treebf8e008c1040f1c51af9b2ff31ba69dcff2f96d4 /configure.ac
parent1b10f791a0139cd64cd51a86150b44abbebb5753 (diff)
downloaddistcc-git-b62a519f6c1436224385f956015c024f71841b70.tar.gz
Instead of a hack to figure out if pump is installed or not -- one
that fails on macs with python 2.5 (at least) because of weirdnesses with distutils installation on that platform -- just rewrite pump at install-time to indicate it's installed. We take the opportunity to tell pump where the installed include_server.py is, because it needs to know, and we know that during 'make install'. Tested by running 'make distcheck' on linux (ubuntu) with python 2.4, and mac 10.5 with python 2.5. I also tested by running, on the linux machine, ./configure --prefix=/tmp/distcc.install && make install && make DISTCC_INSTALLATION=/tmp/distcc.install/bin installcheck Furthermore, I manually inspected the installed pump file after that to make sure it looked correct. Reviewed by klarlund@google.com and fergus@google.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9de33c3..8970999 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,21 +221,15 @@ AC_ARG_VAR(PYTHON, [Python interpreter])
if ! "$PYTHON" -V 2>&1 | grep "^Python" >/dev/null; then
TEST_PYTHON=""
INCLUDESERVER_PYTHON=""
- PYTHON_RELATIVE_LIB=""
elif "$PYTHON" -V 2>&1 | grep "^Python 2.1" >/dev/null; then
TEST_PYTHON=""
INCLUDESERVER_PYTHON=""
- PYTHON_RELATIVE_LIB=""
elif "$PYTHON" -V 2>&1 | grep "^Python 2.[[23]]" >/dev/null; then
TEST_PYTHON="$PYTHON"
INCLUDESERVER_PYTHON=""
- PYTHON_RELATIVE_LIB=""
else
TEST_PYTHON="$PYTHON"
INCLUDESERVER_PYTHON="$PYTHON"
- PYTHON_RELATIVE_LIB=`"$PYTHON" -c \
- "import distutils.sysconfig;\
- print distutils.sysconfig.get_python_lib(prefix=\"\")"`
fi
AC_SUBST(TEST_PYTHON)
AC_SUBST(INCLUDESERVER_PYTHON)