summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Silverstein <csilvers@khanacademy.org>2008-04-12 00:58:56 +0000
committerCraig Silverstein <csilvers@khanacademy.org>2008-04-12 00:58:56 +0000
commitb54c5dec0997a0ccf84b7c87383c471178e9ff16 (patch)
treef98e80ef30b2402518c207a553de75ee31e475bd /configure.ac
parent596cf4e2f019a766965ad0566495c56b7d295fe4 (diff)
downloaddistcc-git-b54c5dec0997a0ccf84b7c87383c471178e9ff16.tar.gz
The second part of my change to hoist everything in the distcc/
directory up to the top level: delete the distcc directory (I already copied it all to the top level in my last commit). This requires changing all files that refer to distcc/FOO to refer directly to FOO instead. Mostly this is Makefile.in and setup.py, but there are a few other changes in scripts that have to hard-code paths, like configure.ac and pump.in. Also, several files changed their comments to refer to the new location, which isn't strictly necessary but I did anyway. The only other change I made was to get rid of the hack I had put in before, which renamed distcc to distcc-bin. I had needed to do that before, temporarily, because "distcc" was already the name of a directory, and couldn't also be the name of a binary. Now that the distcc directory is going away, I can rename the target back to distcc. Tested by running './autogen; ./configure; make maintainer-check'. I also ran 'make pump-check' and 'make distcheck'. To be reviewed (post-facto) by klarlund@google.com and fergus@google.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2af90b0..d6826e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ dnl Process this file with autoconf to produce a configure script
AC_PREREQ(2.53)
AC_INIT(distcc, 3.0-prerelease1, distcc@googlegroups.com)
-AC_CONFIG_HEADERS(distcc/src/config.h)
+AC_CONFIG_HEADERS(src/config.h)
AC_CANONICAL_HOST
# FreeBSD installs its version of libpopt into /usr/local/, but does
@@ -292,10 +292,10 @@ AC_CACHE_SAVE
AC_MSG_CHECKING([whether to use included libpopt])
if test x"$with_included_popt" = x"yes"
then
- AC_MSG_RESULT($srcdir/distcc/popt)
+ AC_MSG_RESULT($srcdir/popt)
# popt_OBJS gets appended to distccd object list
BUILD_POPT='$(popt_OBJS)'
- CPPFLAGS="$CPPFLAGS -I$srcdir/distcc/popt"
+ CPPFLAGS="$CPPFLAGS -I$srcdir/popt"
else
LIBS="$LIBS -lpopt"
AC_MSG_RESULT(no)
@@ -310,7 +310,7 @@ AC_TYPE_SIGNAL
########################################################################
# Checks for library functions, using libraries discovered above
-CPPFLAGS="$CPPFLAGS -I$srcdir/distcc/src"
+CPPFLAGS="$CPPFLAGS -I$srcdir/src"
AC_CHECK_FUNCS([getpagesize])
AC_CHECK_FUNCS([sendfile setsid flock lockf hstrerror strerror setuid setreuid])
@@ -409,8 +409,8 @@ PKG_CHECK_MODULES(AVAHI, [avahi-client >= 0.6],
[AC_DEFINE(HAVE_AVAHI, 1, [defined if Avahi is available])
CFLAGS="$CFLAGS $AVAHI_CFLAGS"
LIBS="$LIBS $AVAHI_LIBS"
-ZEROCONF_DISTCC_OBJS="distcc/src/zeroconf.o"
-ZEROCONF_DISTCCD_OBJS="distcc/src/zeroconf-reg.o"],
+ZEROCONF_DISTCC_OBJS="src/zeroconf.o"
+ZEROCONF_DISTCCD_OBJS="src/zeroconf-reg.o"],
[ZEROCONF_DISTCC_OBJS=""
ZEROCONF_DISTCCD_OBJS=""])
AC_SUBST(ZEROCONF_DISTCC_OBJS)
@@ -429,7 +429,7 @@ AC_SUBST(CPPFLAGS)
AC_SUBST(BUILD_POPT)
AC_SUBST(GNOME_BIN)
AC_DEFINE_UNQUOTED(GNU_HOST, ["$host"], [Your gnu-style host triple])
-AC_CONFIG_FILES([Makefile] distcc/popt/.stamp-conf distcc/lzo/.stamp-conf)
+AC_CONFIG_FILES([Makefile] popt/.stamp-conf lzo/.stamp-conf)
AC_CONFIG_FILES([pump], [chmod +x pump])
AC_OUTPUT