summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Silverstein <csilvers@khanacademy.org>2008-04-17 02:45:29 +0000
committerCraig Silverstein <csilvers@khanacademy.org>2008-04-17 02:45:29 +0000
commit363bfbfa18216a08c4c871f0775a1763def25f38 (patch)
tree8a01b7e4b24f429cd63b2ec38610cba49b33d118 /configure.ac
parent96e78514f30672ca78a78e5cb440d650325ef69c (diff)
downloaddistcc-git-363bfbfa18216a08c4c871f0775a1763def25f38.tar.gz
Resolve some TODO's in the Makefile (and, to a lesser extent, in
configure.ac): 1) Create a .gz tarfile as well as a .bz2 tarfile, with "make dist". I've also added a few more dist rules: "make rpm", "make deb", and "make alldist", though currently they're commented out since the scripts they call have yet to be written. 2) setup.py looks at os.environ("BUILDDIR"), so make sure that environment variable is always set properly. 3) setup.py was hard-coding the version number. Instead, have it get it from the environment ("DISTCC_VERSION"), and set that envvar before calling setup.py in the Makefile. (The alternate solution, of making a setup.py.in and having configure set the version number in setup.py, did not work well because the Makefile really wants setup.py to be in $srcdir, that the configure option puts it in builddir.) 4) Clean up distcheck to have three separate directories: src, build, and install. Before src and build were the same. This pulled up several places that were using srcdir instead of builddir, which I fixed. 5) Clean up distcheck to make sure that 'make distclean' cleans all the build files created during the build. At first it didn't quite, so I fixed that up as well. 6) Added some new files to 'make dist': particularly, the files used to build rpm and deb files. 7) Have maintainer-check and maintainer-installcheck both call the same routine (via recursive make) rather than copy all that code. This simplifies things surprisingly, especially since the main check logic no longer has be inside a big "if $(PYTHON)". 8) (Various rules:) replace $^, which is not very portable, with a repetition of the dependency line. 9) Rename GZIP to GZIP_BIN, since GZIP as an envvar is read by gzip and parsed as gzip options. 10) In include_server/setup.py, we weren't setting builddir/src as an include dir, and it needs to be (as 'make distcheck' shows). I'm not sure builddir/../../src really needs to be anymore, but I guess it can't hurt, so I've left it in. 11) Updated INSTALL to refer to autogen.sh, which will create configure if it's not already there.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d6826e3..3c878f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ dnl Process this file with autoconf to produce a configure script
# As of 0.6cvs, distcc no longer uses automake, only autoconf.
AC_PREREQ(2.53)
-AC_INIT(distcc, 3.0-prerelease1, distcc@googlegroups.com)
+AC_INIT(distcc, 3.0prerelease1, distcc-pump@google.com)
AC_CONFIG_HEADERS(src/config.h)
AC_CANONICAL_HOST
@@ -191,6 +191,7 @@ AC_ISC_POSIX
# This is needed for our included version of popt.
+# TODO(csilvers): figure out what that above comment means, and if it's true.
CPPFLAGS="$CPPFLAGS -DHAVE_CONFIG_H"
# Needed to get various GNU-only functions. They're all autodetected