summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Silverstein <csilvers@khanacademy.org>2008-05-13 01:49:15 +0000
committerCraig Silverstein <csilvers@khanacademy.org>2008-05-13 01:49:15 +0000
commit2d3564ef2c6abb91da348f4c17da7694235acfc8 (patch)
tree1088e1d226dd0431c16e633b0f4f8938b93b30f2 /configure.ac
parent83ee8a226180723f01352cbb9b3760354fe902d1 (diff)
downloaddistcc-git-2d3564ef2c6abb91da348f4c17da7694235acfc8.tar.gz
In the non-included popt case, POPT_INCLUDES was the empty string,
leading to a compile command that had -I"" in it. Who knows what that means? Now the -I is part of POPT_INCLUDES, so when it's absent we don't add anything to CPPFLAGS. Tested on a machine where POPT_INCLUDES is not empty and one where it is. Reviewed by klarlund@google.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cf76dbd..dc984a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,10 +326,11 @@ then
AC_MSG_RESULT($srcdir/popt)
# popt_OBJS gets appended to distccd object list
BUILD_POPT='$(popt_OBJS)'
- POPT_INCLUDES="$srcdir/popt"
+ POPT_INCLUDES='-I"$(srcdir)/popt"'
else
LIBS="$LIBS -lpopt"
AC_MSG_RESULT(no)
+ POPT_INCLUDES=''
fi