summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index ac56bb7..94ebf35 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -3,6 +3,15 @@ man_MANS = \
desktop-file-install.1 \
update-desktop-database.1
+install-exec-hook:
+ cd $(DESTDIR)$(mandir)/man1 && \
+ rm -f desktop-file-edit.1 && \
+ $(LN_S) -f desktop-file-install.1 desktop-file-edit.1
+
+uninstall-hook:
+ cd $(DESTDIR)$(mandir)/man1 && \
+ rm -f desktop-file-edit.1
+
EXTRA_DIST = $(man_MANS)
-include $(top_srcdir)/git.mk