summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build16
1 files changed, 1 insertions, 15 deletions
diff --git a/common/meson.build b/common/meson.build
index 58e0fa8..befa9bc 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -28,19 +28,5 @@ libdconf_common = static_library(
libdconf_common_dep = declare_dependency(
dependencies: glib_dep,
- link_whole: libdconf_common,
-)
-
-libdconf_common_hidden = static_library(
- 'dconf-common-hidden',
- sources: sources,
- include_directories: top_inc,
- dependencies: glib_dep,
- c_args: dconf_c_args + cc.get_supported_arguments('-fvisibility=hidden'),
- pic: true,
-)
-
-libdconf_common_hidden_dep = declare_dependency(
- dependencies: glib_dep,
- link_with: libdconf_common_hidden,
+ link_with: libdconf_common,
)