summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 1a5a5709..21efa98f 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -97,13 +97,17 @@ endif()
install(TARGETS dbus-launch ${INSTALL_TARGETS_DEFAULT_ARGS})
if(WIN32)
- add_executable_version_info(dbus_launch_SOURCES "dbus-monitor")
+ add_executable_version_info(dbus_monitor_SOURCES "dbus-monitor")
endif()
add_executable(dbus-monitor ${dbus_monitor_SOURCES})
target_link_libraries(dbus-monitor ${DBUS_LIBRARIES})
install(TARGETS dbus-monitor ${INSTALL_TARGETS_DEFAULT_ARGS})
+if(WIN32)
+ add_executable_version_info(dbus_run_session_SOURCES "dbus-run-session")
+endif()
+
add_executable(dbus-run-session ${dbus_run_session_SOURCES})
target_link_libraries(dbus-run-session ${DBUS_INTERNAL_LIBRARIES})
install(TARGETS dbus-run-session ${INSTALL_TARGETS_DEFAULT_ARGS})