summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f86e9df..e8fc1aef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1379,6 +1379,8 @@ case $host_os in
solaris*)
# Solaris' C library apparently needs these runes to be threadsafe...
CFLAGS="$CFLAGS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT"
+ # ... this opt-in to get sockaddr_in6 and sockaddr_storage...
+ CFLAGS="$CFLAGS -D__EXTENSIONS__"
# ... and this opt-in to get file descriptor passing support
CFLAGS="$CFLAGS -D_XOPEN_SOURCE=500"
;;