summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2019-04-17 15:18:42 +0000
committerSimon McVittie <smcv@collabora.com>2019-04-17 15:18:42 +0000
commit177ef29188c430e7e137e1d27e0b462a63190b4f (patch)
tree8cb2f854a945b2a8f4344a6b9a5c6e8babbc2796 /test/Makefile.am
parent6ef67cff6ba26645f9cbe23ffb401f3d49a66429 (diff)
parentd9ef0226e2ff346f80c0c8ba1a0fec19c553b458 (diff)
downloaddbus-177ef29188c430e7e137e1d27e0b462a63190b4f.tar.gz
Merge branch '1-12-code-coverage' into 'dbus-1.12'
Adapt to API change in AX_CODE_COVERAGE version 28 See merge request dbus/dbus!108
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6a6e1a30..746ed314 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -39,9 +39,9 @@ libdbus_testutils_la_SOURCES += \
endif
libdbus_testutils_la_LIBADD = \
+ $(CODE_COVERAGE_LIBS) \
$(top_builddir)/dbus/libdbus-1.la \
$(top_builddir)/dbus/libdbus-internal.la \
- $(CODE_COVERAGE_LDFLAGS) \
$(NULL)
TEST_EXTENSIONS = .sh
@@ -672,4 +672,4 @@ $(installable_test_meta_with_config): %_with_config.test: %$(EXEEXT) Makefile
) > $@.tmp && mv $@.tmp $@
# Add rules for code-coverage testing, as defined by AX_CODE_COVERAGE
-@CODE_COVERAGE_RULES@
+include $(top_srcdir)/aminclude_static.am