summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-06-15 11:41:27 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-07-29 11:16:44 +0100
commitf7b7de3bb14d29ab02d1e713036467adc6b9cb56 (patch)
tree23f3b012ac40002b0ef0d11230d66a1b37268ad2 /dbus/Makefile.am
parent42d7a573cff2febb9938e30edcebc420e0f40195 (diff)
downloaddbus-f7b7de3bb14d29ab02d1e713036467adc6b9cb56.tar.gz
Don't explicitly link thread and network libs into various tests
These tests get everything they need from the public or internal API of libdbus-internal.la, and libtool knows how to pull in libraries' dependencies, so we don't need explicit linking. spawn-test and break-loader don't actually need test-utils.[ch] either.
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index af34bd4b..c33cb61b 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -280,7 +280,7 @@ endif
dbus_test_SOURCES= \
dbus-test-main.c
-dbus_test_LDADD=libdbus-internal.la $(DBUS_TEST_LIBS)
+dbus_test_LDADD = libdbus-internal.la
## mop up the gcov files
clean-local: