summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2010-02-09 19:44:12 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2010-02-09 19:44:12 +0100
commit31d9f4d655416caf499cdab4019a453650fb2d72 (patch)
tree65ea1af635e7e806b00c59fe2b3f7f458646bc52 /dbus/Makefile.am
parent413c3537b8730940d516af4823e83ac8df001ede (diff)
parent523e01827eac49ec30afa173d31cdeee4be6381a (diff)
downloaddbus-31d9f4d655416caf499cdab4019a453650fb2d72.tar.gz
Merge branch 'master' of ssh://git.freedesktop.org/git/dbus/dbus
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index b2a98797..3e733fac 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -23,6 +23,10 @@ SUFFIXES = rc
dbus_res = versioninfo.o
dbus_res_ldflag = -Wl,$(dbus_res)
no_undefined = -no-undefined
+
+
+### FIXME use the .def.in files depending on the current config
+### or combine them in a single .def file as done in the cmake build
export_symbols = -export-symbols $(srcdir)/dbus-1.def
install-def-file:
@@ -109,7 +113,6 @@ dbusinclude_HEADERS= \
dbus-server.h \
dbus-shared.h \
dbus-signature.h \
- dbus-spawn.h \
dbus-threads.h \
dbus-types.h
@@ -251,6 +254,7 @@ noinst_LTLIBRARIES=libdbus-convenience.la
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS)
libdbus_1_la_LDFLAGS= $(export_symbols) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined @R_DYNAMIC_LDFLAG@ @PIC_LDFLAGS@
+libdbus_convenience_la_LIBADD=$(DBUS_CLIENT_LIBS)
libdbus_convenience_la_LDFLAGS=@R_DYNAMIC_LDFLAG@
## note that TESTS has special meaning (stuff to use in make check)