summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-01-23 11:11:24 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-01-23 11:11:24 +0000
commit11b31b864fe7aad4084544f9f846a2ddfe39c28a (patch)
tree9911fc680a5871cb06efe92a509268e509854d7e /configure.ac
parent61758931005407de85952169e8253a72805e59ef (diff)
downloaddbus-11b31b864fe7aad4084544f9f846a2ddfe39c28a.tar.gz
Port to glib 2.31.x g_thread API
g_thread_init() is deprecated since glib 2.24, call g_type_init() instead. Bump glib requirement accordingly. g_thread_create is deprecated since 2.31, use g_thread_new() instead. When building with a glib earlier than 2.31, provide a backwards compatibility shim. [Added a comment about why we're using g_type_init() in a test that doesn't otherwise use GObject -smcv] Bug: https://bugs.freedesktop.org/show_bug.cgi?id=44413 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 243cbbcd..3ca922b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,7 +192,7 @@ fi
# default (unless you don't have GLib), because they don't bloat the library
# or binaries.
if test "x$enable_modular_tests" != xno; then
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.22, gio-2.0 >= 2.22],
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.24, gio-2.0 >= 2.24],
[],
[if test "x$enable_modular_tests" = xyes; then
AC_MSG_NOTICE([Full test coverage (--enable-modular-tests=yes or --enable-tests=yes) requires GLib])