summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-06-25 15:42:23 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-06-25 12:26:59 +0100
commite632ceab0acc280bf1163dcde1853495599868e2 (patch)
tree41eaa02b39dac05fd435ed6be385ae6d480448e8 /configure.ac
parent2fe0e999347e7e665ac21c2c53c026d53cd9a163 (diff)
downloaddbus-e632ceab0acc280bf1163dcde1853495599868e2.tar.gz
Explicitly define macros to get less confusing conditions
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=65990 Signed-off-by: Chengwei Yang <chengwei.yang@intel.com> Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c63f982..782dfbae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -297,6 +297,15 @@ if test x$enable_checks = xno; then
DISABLE_UNUSED_WARNINGS="unused-label"
fi
+AH_BOTTOM([
+/* explicitly define these macros to get less confusing conditions */
+#ifndef DBUS_DISABLE_ASSERT
+# define DBUS_ENABLE_ASSERT 1
+#endif
+#ifndef DBUS_DISABLE_CHECKS
+# define DBUS_ENABLE_CHECKS 1
+#endif])
+
if test x$enable_userdb_cache = xyes; then
AC_DEFINE(DBUS_ENABLE_USERDB_CACHE,1,[Build with caching of user data])
fi