summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-09-04 15:13:33 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-09-13 14:59:20 +0100
commitba58504ad266cd2b053ed0f923491889722cf8eb (patch)
treeb40808c4fcd9ea0e837405483af9a7f32485d3e7 /configure.ac
parent86c6dbd20b578e28f383ade7c9af1572e4169347 (diff)
downloaddbus-ba58504ad266cd2b053ed0f923491889722cf8eb.tar.gz
Make userdb cache as a built-in feature
The disable-userdb-cache code path is never been fine tested and you could expect an extramely slow bus if you did that. And there are known bugs on fd.o if build without userdb cache. So to prevent user from using bus without userdb cache, it changed to a built-in feature, no longer optional now. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=66947 Bug: https://bugs.freedesktop.org/show_bug.cgi?id=15589 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b6ff7690..da4ab5fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,7 +153,6 @@ AC_ARG_ENABLE(libaudit,AS_HELP_STRING([--enable-libaudit],[build audit daemon su
AC_ARG_ENABLE(inotify, AS_HELP_STRING([--enable-inotify],[build with inotify support (linux only)]),enable_inotify=$enableval,enable_inotify=auto)
AC_ARG_ENABLE(kqueue, AS_HELP_STRING([--enable-kqueue],[build with kqueue support]),enable_kqueue=$enableval,enable_kqueue=auto)
AC_ARG_ENABLE(console-owner-file, AS_HELP_STRING([--enable-console-owner-file],[enable console owner file]),enable_console_owner_file=$enableval,enable_console_owner_file=auto)
-AC_ARG_ENABLE(userdb-cache, AS_HELP_STRING([--enable-userdb-cache],[build with userdb-cache support]),enable_userdb_cache=$enableval,enable_userdb_cache=yes)
AC_ARG_ENABLE(launchd, AS_HELP_STRING([--enable-launchd],[build with launchd auto-launch support]),enable_launchd=$enableval,enable_launchd=auto)
AC_ARG_ENABLE(systemd, AS_HELP_STRING([--enable-systemd],[build with systemd at_console support]),enable_systemd=$enableval,enable_systemd=auto)
@@ -316,10 +315,6 @@ AH_BOTTOM([
# define DBUS_ENABLE_CHECKS 1
#endif])
-if test x$enable_userdb_cache = xyes; then
- AC_DEFINE(DBUS_ENABLE_USERDB_CACHE,1,[Build with caching of user data])
-fi
-
if test x$enable_compiler_coverage = xyes; then
## so that config.h changes when you toggle gcov support
AC_DEFINE_UNQUOTED(DBUS_GCOV_ENABLED, 1, [Defined if gcov is enabled to force a rebuild due to config.h changing])
@@ -1864,7 +1859,6 @@ echo "
Building X11 code: ${have_x11}
Building Doxygen docs: ${enable_doxygen_docs}
Building XML docs: ${enable_xml_docs}
- Building cache support: ${enable_userdb_cache}
Building launchd support: ${have_launchd}
Init scripts style: ${with_init_scripts}
Abstract socket names: ${ac_cv_have_abstract_sockets}