summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-09-16 17:40:29 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-09-28 19:00:11 +0100
commit6934bc6927a3846d096bd3549f0ed06c901bb9f2 (patch)
tree15de860bfd12e9e223175768d07a6a8ecfa871ef /configure.ac
parentba033709b54df18bbe48b22303e0c3d514f547f8 (diff)
downloaddbus-6934bc6927a3846d096bd3549f0ed06c901bb9f2.tar.gz
Simplify generation of bus configuration files
Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=41222
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 3 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 66bcf20a..6c2e2b51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1519,12 +1519,6 @@ DBUS_PWD=`pwd`
# Useful in a cross-compilation environment, where the tests are run on the host system.
AC_ARG_WITH(dbus-test-dir, AS_HELP_STRING([--with-dbus-test-dir=[dirname]],[path where the tests tools are available]),
DBUS_PWD=$withval)
-AC_DEFUN([TEST_PATH], [
-TEST_$1=${DBUS_PWD}/test/$2
-AC_DEFINE_UNQUOTED(TEST_$1, "$TEST_$1",
- [Full path to test file test/$2 in builddir])
-AC_SUBST(TEST_$1)
-])
AC_DEFUN([TEST_PROG], [
TEST_$1=${DBUS_PWD}/test/$2
AC_DEFINE_UNQUOTED(TEST_$1, "$TEST_$1$EXEEXT",
@@ -1532,10 +1526,9 @@ AC_DEFINE_UNQUOTED(TEST_$1, "$TEST_$1$EXEEXT",
AC_SUBST(TEST_$1)
])
-TEST_PATH(VALID_SERVICE_DIR, data/valid-service-files)
-TEST_PATH(INVALID_SERVICE_DIR, data/invalid-service-files)
-TEST_PATH(VALID_SERVICE_SYSTEM_DIR, data/valid-service-files-system)
-TEST_PATH(INVALID_SERVICE_SYSTEM_DIR, data/invalid-service-files-system)
+DBUS_TEST_DATA="$DBUS_PWD/test/data"
+AC_SUBST([DBUS_TEST_DATA])
+
TEST_PROG(SERVICE_BINARY, test-service)
TEST_PROG(SHELL_SERVICE_BINARY, test-shell-service)
TEST_PROG(EXIT_BINARY, test-exit)