summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-05-25 17:39:34 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-05-25 17:39:34 +0100
commitfd99c3a1c16ff645e9d080574bdb999de7ee65f2 (patch)
tree90d5913ef9f67b188dc3b662dcfd64755a40a72d /configure.ac
parenteef30df87a732e756c844df7f99ffc6e86979f01 (diff)
parentcea055514a9dfc74e7f0515cf4a256da10a891bc (diff)
downloaddbus-fd99c3a1c16ff645e9d080574bdb999de7ee65f2.tar.gz
Merge branch 'dbus-1.4'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b51b842e..c43fe733 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1100,9 +1100,6 @@ if test "x$dbus_win" = xyes; then
fi
enable_x11_autolaunch=no
-fi
-
-if test "x$enable_x11_autolaunch" = xno; then
have_x11=no
else
AC_PATH_XTRA
@@ -1120,11 +1117,17 @@ if test "x$enable_x11_autolaunch,$have_x11" = xyes,no; then
AC_MSG_ERROR([X11 auto-launch requires X headers/libraries])
else
# move from "auto" to "yes" or "no" if necessary
- enable_x11_autolaunch="$have_x11"
+ if test "x$enable_x11_autolaunch" != xno; then
+ enable_x11_autolaunch="$have_x11"
+ fi
+fi
+
+if test "x$have_x11" = xyes ; then
+ AC_DEFINE([DBUS_BUILD_X11], [1], [Define to build X11 functionality])
fi
if test "x$enable_x11_autolaunch" = xyes ; then
- AC_DEFINE([DBUS_BUILD_X11], [1], [Define to enable X11 auto-launch])
+ AC_DEFINE([DBUS_ENABLE_X11_AUTOLAUNCH], [1], [Define to enable X11 auto-launch])
fi
AC_SUBST([DBUS_X_CFLAGS])