summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-07-25 13:37:52 +0100
committerSimon McVittie <smcv@collabora.com>2018-02-07 07:34:35 +0000
commit97d480c09c66ad7860f6c0e0a3d56fdf3a0d56a8 (patch)
tree04c4445e607b76cbdf30b8e458039aae7cc3ff4e /configure.ac
parentd4d6cdab994f99d4e9613a1ee0c8ec6bebec3f1c (diff)
downloaddbus-97d480c09c66ad7860f6c0e0a3d56fdf3a0d56a8.tar.gz
cmake: Match AC_DEFINE more precisely, respecting [] quoting
The regular expression previously used here to select the second comma-delimited argument won't work when we introduce an argument containing a comma, which I need to do now. We can address this by recognising Autoconf's quoting mechanism (which uses square brackets). This is not 100% right (it doesn't understand nested square brackets), but it's good enough in practice. Signed-off-by: Simon McVittie <smcv@collabora.com> Acked-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101354 (cherry picked from commit 83b439f7b4c6a946e0fe9a0287910ba4f6318143)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 132e1630..413f6580 100644
--- a/configure.ac
+++ b/configure.ac
@@ -258,6 +258,9 @@ fi
# default (unless you don't have GLib), because they don't bloat the library
# or binaries.
+dnl Don't do anything too subtle here, because the CMake build system
+dnl parses these lines with regular expressions. If necessary, adjust
+dnl cmake/modules/MacrosAutotools.cmake to compensate.
AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_40], [Ignore post-2.40 deprecations])
AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_40], [Prevent post-2.40 APIs])