summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-06-09 14:46:32 +0100
committerSimon McVittie <smcv@collabora.com>2017-06-12 11:40:18 +0100
commit8821af59c8b94fdc22b1ed1217cbce80791b4222 (patch)
tree9340fe99a6567622978b69a94d9f47dffa00490d /configure.ac
parente98d907f7e3c391dd20aac2409a89b2681c847fa (diff)
downloaddbus-8821af59c8b94fdc22b1ed1217cbce80791b4222.tar.gz
Bump GLib dependency for tests to 2.40
This is quite old (it's the version in Ubuntu 14.04 LTS, and older than the version in Debian 8) but gives us g_test_skip(), g_test_trap_subprocess() and GVariantDict, all of which will be useful in the regression tests. Remove workarounds for old versions. After this commit we are still using the deprecated g_test_trap_fork(), which will be removed in a subsequent commit. Don't opt-in to the new deprecation warnings from 2.38 and 2.40 yet, because under our recommended settings for dbus developers (-Werror) they would break the build. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101362
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b05c708b..dcfcb4e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,13 +263,13 @@ fi
# or binaries.
AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36], [Ignore post-2.36 deprecations])
-AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_38], [Prevent post-2.38 APIs])
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_40], [Prevent post-2.40 APIs])
with_glib=yes
AS_IF([test "x$enable_modular_tests" != xno],
[
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.36, gio-2.0 >= 2.36],
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.40, gio-2.0 >= 2.40],
[
AS_IF([test "x$dbus_unix" = xyes],
[PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0],