summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2014-01-27 08:54:27 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2014-01-30 17:09:41 +0100
commitea1884e3e5c30c681e1935476b4701166c43125c (patch)
tree0609c73719ffe50c9b187ee32758bae8a9475549 /cmake/CMakeLists.txt
parentfb84b3e592f14c3f25a9a04ab1a6262819a415f4 (diff)
downloaddbus-ea1884e3e5c30c681e1935476b4701166c43125c.tar.gz
Keep cmake generated shared dbus-1 library file name in sync with autotools.
Autotools uses a versioned shared library name derived from libtool. This patch adds a versioned shared library name to cmake builds for all supported platforms. Binary compatibility for clients build against older cmake generated binary packages of dbus is provided; on unix like os with symbolic links and on Windows with a copy of the shared library. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=74117 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index b7c25299..41882d73 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -136,7 +136,6 @@ if(VCS)
endif(VCS)
if(WIN32)
- set(CMAKE_DEBUG_POSTFIX "d")
if(MSVC)
# controll folders in msvc projects
include(ProjectSourceGroup)