summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2011-07-03 00:54:20 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2011-07-03 01:39:09 +0200
commit84b03cae585274bfe54e2a234dff72469cef581d (patch)
treecbd3de2290eb4f814b5ea0db418209e07c0cfe0d /cmake/CMakeLists.txt
parentb77885c1db16dd2ebe4db17846b1470864d7c62d (diff)
downloaddbus-84b03cae585274bfe54e2a234dff72469cef581d.tar.gz
Limit batch file creating to windows
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 34a1083b..ede0d3b8 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -502,8 +502,12 @@ set (DBUS_INTERNAL_LIBRARY_DEFINITIONS "-DDBUS_STATIC_BUILD")
set (DBUS_INTERNAL_CLIENT_DEFINITIONS "-DDBUS_STATIC_BUILD")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h )
+
+if (WIN32)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/dbus-env.bat.cmake ${CMAKE_BINARY_DIR}/bin/dbus-env.bat )
install_files(/bin FILES ${CMAKE_BINARY_DIR}/bin/dbus-env.bat)
+endif()
+
add_definitions(-DHAVE_CONFIG_H=1)
########### subdirs ###############