summaryrefslogtreecommitdiff
path: root/_dbus_bindings/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '_dbus_bindings/Makefile.am')
-rw-r--r--_dbus_bindings/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/_dbus_bindings/Makefile.am b/_dbus_bindings/Makefile.am
index e0fb889..42c9f91 100644
--- a/_dbus_bindings/Makefile.am
+++ b/_dbus_bindings/Makefile.am
@@ -7,6 +7,20 @@ AM_LDFLAGS = -module -avoid-version \
libadd = $(DBUS_LIBS)
+if WINDOWS
+# Win32 DLLs can't have undefined symbols (so this needs explicit linking
+# against the Python DLL), and Python expects extensions to be *.pyd
+# instead of *.dll
+AM_LDFLAGS += \
+ -no-undefined \
+ -shrext ".pyd" \
+ $(NULL)
+
+libadd += \
+ $(PYTHON_LIBS) \
+ $(NULL)
+endif
+
_dbus_bindings_la_LIBADD = $(libadd)
_dbus_bindings_la_SOURCES = \
abstract.c \